Problem opening .gpkg file

I am working on Nutrient Delivery Model. However, I cannot open the watershed_results_ndr.gpkg file in ArcGIS. Please help.

Hi @Aditi_Majumdar -

Geopackages aren’t very well supported by ArcGIS, unfortunately. You can’t just drag and drop them in like many other file formats. I’m not sure how you’re trying to open it, but here’s what works for me:

1/ Go to Add Data, and navigate to the location of the .gpkg.
2/ Double-click on the .gpkg.
3/ Double-click on the layer within the .gpkg that you want to add to the map session.

I’ve had trouble doing things like editing geopackage attribute tables within ArcGIS too, so if you want to do additional processing on it, I’d recommend exporting to a shapefile first.

~ Stacie

1 Like

Thank you for your prompt response. However, I am still not able to open it. Any other suggestions please? (2.3 MB)

I just tried opening watershed_results_ndr_NDR.gpkg in both ArcGIS Pro and Desktop, using the instructions I provided, and it worked with both of them, the layer appears in the map fine (although the watershed itself is a 22 kilometer square, which is strange). Is Arc giving you an error when you try to add the data? What exactly is happening?

~ Stacie

Arc is not showing an error. The data is not opening only. It shows a blank screen.

Interesting. Have you tried “Zoom to layer”? Does it appear then? It might just be too small to see, depending on the zoom level of your map session.

If it still doesn’t appear, then one workaround could be to use a tool like “Feature class to shapefile” to translate the geopackage layer to a shapefile, then add the shapefile to your map.

If neither of these work then sorry, but I can’t help debug Arc, you’ll have to look to other resources.

~ Stacie

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.