Problem with NoData values in SDR

Hello. I’m struggling to fix an issue running the SDR model due to what seems to be the existence of NoData values on the lulc raster dataset which do not correspond to any values in the biophysical table, according to another topic I’ve seen on this forum. This is the message I’m receiving:
I checked the lulc raster and the NoData value assigned to it is -128, which is the exact same value the message informs me of. How can I solve this, please?
Thank you all in advance.

Hi @gabriel_1610 -

I suspect you’re running into the same issue as is discussed in this forum post. Check it out, try the workaround described there and let us know if it helps.

~ Stacie

1 Like

Hi @gabriel_1610,

Ah, in the amazing 30 minutes it took me to get this reply together I see Stacie posted too! Here’s what I was going to suggest since InVEST 3.9 will be out very soon!

This could be a bug with how GDAL deals with signed / unsigned types. Could you try downloading and using the development version of InVEST SDR?

I think we might have handled this issue.


Hello @dcdenu4 and @swolny, thanks for the replies! I’ll make sure to test what both of you have suggested and I’ll be back with an update. Thanks again, cheers.

I tried both suggestions and the workaround creating a new entry on the biophysical table with the lucode 128 and both C and P assigned as 0, as said by @swolny worked for me! Unfortunately @dcdenu4, the development version you linked me couldn’t solve the issue presented.
Anyways, thanks for the help everyone. Have a great day!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.