Projection Error message - RIOS Investment Portfolio Advisor

RIOS Investment Portfolio Advisor is giving me an error message saying that 2 of my input raster files (the LULC raster & soil depth raster) have no projection. The raster files are projected (WKID: 2953 Authority: EPSG) and they do work OK in the RIOS Data PreProcessor. All the other raster input files in the same projection seem to have been accepted as inputs by the RIOS Investment Portfolio Advisor? I have tried re-projecting or re-defining the projections of these 2 raster files indicated, and also tried re-saving the 2 files to several different raster file formats as alternative input files, but none of those attempts will fix this error.

Do you have any suggestions? Thanks.

(error text is in the log txt file uploaded attached)

natcap.rios-log-2020-02-11–20_02_18.txt (17.0 KB)

Gordon (user: BVIB)

Hm, well that is curious. Is it possible for you to send me your inputs so I can try them out? If so, you can send a link to swolny at stanford.edu.

~ Stacie

Hi Stacie. Yes, thanks…I could send you my 10 input files for the RIOS Invest Port Adv model (for the erosion - water quality, for example) . However, the 10 files are collectively around a total of 8.2 GB. Their large file size is due to being their generated using a LiDAR-derived 1 m x 1m X-Y resolution DEM for whole area of the 264 km2 of the watershed here. The 8.2 GB would probably take about 2 to 4 hours to transfer to you at my local ISP upload speeds (nominal upload rate here 10 Mb/s), I think. Not sure if the file transfer connection will persist that long without dropping out or hitting routine timeout logouts? Worth a try ! I would be interested in having your input on my file projection difficulty and your assessment of my files for the RIOS model in general. If you think we can manage the 8.2 GB files transfer OK, send me the upload link and I will send the files. Thanks !!

Gordon (user: BVIB)

Note that: there is are some small local partial discontinuities in the north end of some of my watershed raster files which I have not been able to eliminate as yet…but I will do so as I have time to work on it. They do not appear to be the source of the projection-read difficulty as near as I can tell.?

1 Like

Yes, that’s a lot of data. Given the error, it might be useful enough if you can provide both of the inputs that the model is complaining about, as well as one that it isn’t complaining about, so I can compare their coordinate systems etc. Would that make the upload size more manageable? Zipping also tends to help with overall size, so zip them up and see if that helps. Maybe zip them individually, so it’s more likely for the file transfer to make it through each one without dropping. Do you have a Dropbox/Google Drive/Box/whatever kind of place to upload and share data?

~ Stacie

~ Stacie

Thanks again Stacie. Good suggestion. I have uploaded on to my DropBox my 2 raster files that the RIOS InVest Port Adv cannot read the projection of and one of my raster files that it can (all same projection). Let me know where/how best to share that with you and I will do so.

Appreciated.

Gordon (BVIB)

Great, Gordon. Can you send a Dropbox link to my email address - swolny at stanford.edu? If you put all of the rasters in one folder in Dropbox, you can just share the folder link. Or send separate links to each zipfile, works for me either way. Thanks.

~ Stacie

Thanks Stacie. I have shared the DropBox folder with you. The 3 files are in the folder in one zip file. These 3 are smaller files fortunately anyhow, my other 7 files were the large files.

Did you send me the links by email? If so, I haven’t received them.

~ Stacie

Hi Gordon -

Thanks for sending your data, however, none of the file names match what I see in the log file that you posted, so it’s hard to tell if I’m evaluating things correctly.

If they are the same layers, just renamed, I would guess that “ESA_CCI_copied.tif” in the log file corresponds to “RasterLUCODE.tif” and/or “RasterLUCODE_ProjectRaster1.tif” in the data. And “soil_depth_copied.tif” corresponds to “RasterProf.tif” in the data. Is this correct?

If so, I see what you mean, that most of the layers are projected with coordinate system MAGNA_Colombia_Bogota (as shown in ArcGIS, QGIS shows ESPG:3116 MAGNA-SIRGAS / Colombia Bogota.) One layer is not the same, RasterBenefi.tif, which is MAGNA_Transverse_Mercator in Arc, which is seen as an invalid projection in QGIS, so this one should be reprojected to match the rest.

I’m really not sure why RIOS is complaining about these two only, but I wonder if it doesn’t support the coordinate system MAGNA_Colombia_Bogota properly. Could you try reprojecting all of your inputs to something that we know generally works in RIOS, like UTM, and see if that changes anything?

~ Stacie

Thanks Stacie. Very curious. All my input files show here both in ArcGIS and in QGIS as being in EPSG 2953 (a local NAD83 CSRS variant) projection. Also, you are correct that the input file names I submitted into the RIOS model have no correspondence to the input file names seen in the log file. Again, not sure why. I will check everything here again. Thanks again. Sorry to be a bother!.

Hi Gordon and Stacie!
I think we have a little confusion, cause the projection system MAGNA_Colombia_Bogota corresponds to my data, we both send .zip to Stacie :rofl: :rofl: … I have the same problem that Gordon, the same rasters “without” projection.
We are very grateful for your help, Stacie!

I wondered if that was the case @Albaluz! Well, let me know if changing the coordinate system to UTM makes the problem go away or not. If not, I’ll probably need the whole set of input data for further debugging.

~ Stacie

Hi Stacie and Albaluz:

Yes !.. changing the coordinate system of all my raster input files to a UTM coordinate system (WGS84 & UTM19N for this particular watershed) makes the problem go away for me. THANKS ! Appreciate the help.

On to the next step… :slightly_smiling_face:

Gordon (user: BVIB)