RIOS RESULTS Investment Portfolio Adviser

Hello again, it’s Alba from Colombia
If anyone could help me, I really appreciate it. When I run RIOS Investment Portfolio Adviser, the results look “broken” or “cut,” however, it doesn’t give me any errors in the process. Is something wrong with my Inputs?

Hi Alba, Would you mind sharing the logfile from this run and your input data? I think that’s the only way we’ll be able to advise on why this happened.

You may send me a private message with a link to your data if you won’t want to post it here. Google drive or dropbox usually work well.

1 Like

Hi Alba -

Sorry it took so long for me to look at this. Although in the end I’m not sure why that linear pattern is happening. @dave pointed me to your input data, and when I run it through RIOS I get a different result - you can see it attached. I might not have gotten all of your weights or budget exactly the same, but I don’t think that should matter for this testing, and I tried it with multiple budgets too. To make sure that I’m using the same inputs as you, could you do this in the RIOS IPA window: File > Save Parameters, and send me the resulting .json file?

I don’t see anything obviously wrong with the inputs or pre-processor layers. One thing I do see that’s odd in your IPA outputs is that the rasters in activity_scores all seem to have bad data in them, I can’t visualize any of them in a GIS. But when I run (what I think are) the same inputs, those rasters have values as expected (between 0 and 1.) The other more intermediate outputs from your IPA output that I’ve looked at (objectives, transition scores) do not have the same problem.

As a side note, the stream network created by the pre-processor is extremely dense, like there’s as much stream as land in this watershed - is this how it is in reality? If not, I suggest adjusting the threshold flow accumulation until streams.shp looks more like a real-world stream network.

~ Stacie

1 Like

Hello Stacie and Dave
Thanks for the help! As a first step, I am adjusting the threshold flow accumulation, as soon as I have the .json file, I will write here again.
Many thanks!

Hi Stacie and Dave, sorry for write again… the emergency for the covid 19 terribly damaged my work, so far I can run the model again.
I still obtain the same “broken” pattern in the final output :sob:
The same way, I can’t see the activity rasters. Also, I corrected the threshold flow accumulation (1500). As you ask me, I send you the json file resulting.
I’m really grateful with you, in my institute don’t have anybody to ask about this. (1.6 KB)

Thanks for providing the json parameter file @Albaluz. Unfortunately, I was unable to import it into RIOS (there seems to be a bug…) but, I think I see what’s wrong, and was able to replicate your output.

The problem seems to be in the Transition Potential table. All of these values are set to 0, when RIOS expects some of them to be set to 1. A value of 1 indicates that this management activity causes a particular landscape transition. For example, “riparian_mgmt” can cause “Revegetation (assisted)”, if riparian management involves restoring riparian vegetation.

Each management activity that you define must have a 1 for at least one of the transitions listed across the top of the table in the Transition Potential tab. All others should have a value of 0. Try changing this and let us know if the output looks better.

I’ll also let you know that RIOS isn’t really supported by NatCap any more. We’re currently updating the website to let people know. So while we can provide minimal forum support, we won’t be creating new releases, bug fixes or providing any in-depth support. I’m kinda sad to see it go!

~ Stacie

OMG Stacy, is a very sad new… Can we know since when will be RIOS outta CNP? Will be the software still available on the web? :broken_heart:
In the next opportunity to get into my lab (next week hope), I’ll fix those parameters and let you know if works.
Again, thanks a lot for your help.

Hi @Albaluz -

No, we will not provide the executable software any more, only the source code and documentation in case someone is curious about how it works, or wants to build off of the software with their own code additions. We simply haven’t had the resources to continue support (which is one of the downsides of being a non-profit.)

I can recommend checking out ROOT as an alternative. While its input requirements are more complex, it does more of a true optimization, which RIOS does not.

~ Stacie

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.