SDR error: 'usle_c'

I keep running into a problem at the beginning of running the SDR model: KeyError encountered: ‘usle_c’.
I’ve found a few helpful posts on this forum, including this one and have ensured that my lulc grid is reclassed properly, has no extra values, and that the values in the lulc raster match the lulc values in the biophysical table. The biophysical table has the columns usle_c and usle_p in addition to the lulc value as required.

I have also checked my .csv in a text editor to confirm that the values are comma separated per this post (May 23, swolny): Sdr execution issue

Are there any other tips to get me beyond this error?
Thank you!

Hi @EcosysGIS -

It sounds like you’ve done your homework - thanks for letting us know what all you’ve tried. I’m surprised that it’s not a problem with the csv being not comma-separated, that’s often the problem when the model gives a KeyError on a required field name. One last thing to check that you haven’t mentioned is to make sure there is not a blank line at the bottom of the csv file (which you can also see in a text editor) - if there is, remove it and see if that helps.

If it doesn’t help, point me to your data and I’ll check it out.

Oh, one more thing: when you get an error, it’s often helpful if you post the whole log file (.txt) that the model produces in the Workspace. Sometimes that has additional information that can help us debug.

~ Stacie

Stacie, thank you so much for your quick reply! I re-checked the .csv in a text editor, and happened to notice an extra space after the usle_c before the comma. I deleted the space, and it worked!
However, I’m now getting a different error that I cannot find on the forum. It says "unfunc ‘isfinite’ not supported for the input types, and the inputs could not be safely coerced to any supported types according to the casting rule “safe”.
I’ll attach the log fileInVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2019-07-05–15_58_05.txt (9.1 KB)

Do you have any idea?

Sorry, @EcosysGIS, I don’t have a clue about that error - @rich, @jdouglass?

~ Stacie

Hi @EcosysGIS, I think we’ll need your data stack to debug that. Can you dropbox/google drive share it to