SDR only outputs half of the area I'm working with

InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2021-02-28–17_15_37.txt (87.8 KB) Dear community and developers,

I am working with te SDR with version 8.9. It has worked fine for all my other study areas but for this particular one, despite multiple tries, only outputs half of the wanted area or less. The runs is also pretty quick, arround 6-10 min compared to correct runs which last about 1 hr. I have checked the files multiple times, so now I share this issue with all of, maybe someone can help?


Hi @felipebenra,

I noticed in your log that some files failed to delete ( Invest_output\sed_retention_1.tif failed: Permission denied ). Is it possible you were overwriting this workspace but had these files open somewhere else?

I’m not exactly sure how this would cause only half the output area, but maybe it’s a good place to start.



Hi @dcdenu4,

I think I can rule that out as the file was not open elsewhere. If that was the case I think the process would not overwrite it at all or not? but it just overwrites about half of the wanted area and then it stops.

I installed version 3.9 and will let you know how that went.


1 Like

Hey @felipebenra ,

Keep us posted!

@dcdenu4 and community,

The process worked with version 3.9.