Unable to run 3.7.0 on Windows 10

Hello professior:
I have many problems to ask.
At first I setup 3.6.0. on windows but I can’t tun it.
And then I setup 3.6.0 post34+he2e589f406d8-py2.7-win32.egg on windows and used python to run it successfully. However when I added my data I faced the arrtibuteError: ‘NoneType’ object has no attribute ‘GetRasterBand’.
So I went back and projected all my data and try again but it get the same wrong results.

Finally I tried 3.7.0 and use the test data and met the same Error? I want to ask that How can I fix it ? Is there any wrong with my computer?(windows 10)
InVEST-Hydropower-Water-Yield-log-2019-05-28–10_56_13.txt (9.9 KB)

The only version I can use is 3.3.3.post33+n833418107536 and it can run successfully. Is the result right? If it is right can I get the python of this old version? even though the 3.3.3. post 30 can’t run well. Maybe if I can set up this version(3.3.3.post33+n833418107536 python2) will it fix the problem and is that right?
natcap.invest.hydropower.hydropower_water_yield-log-2019-05-28–11_02_46.txt (82.1 KB)

I just overcame the problem. Because the name of my computer is Chinese!