Unable to run Invest 3.6.0 and 3.4.4 on Mac OS

#1

Hi all,

I am just trying to instal and run InVEST on my Mac (OS Sierra version 10.12.6). I understand that the app is from an unidentified developer and gave it the necessary permissions but it’s still not working. It just blinks and closes.

Just want to know how to solve this. Any leads would be great.

Thanks!
Niyati

#2

Hello @Niyati,

There’s a pretty good chance that the crash is happening because of the difference in OS versions. The mac InVEST binaries are built on High Sierra (OSX 10.13), and I suspect that upgrading to High Sierra or later will address the issue. Hopefully that won’t be too big of a request?

This isn’t the first time this sort of thing has come up, and I do hope that we’ll be able to support a greater range of OSX versions, but this is the unfortunate state of things at the moment.

I’m sorry for the inconvenience here, and hope this helps!
James