InVEST 3.3.3 ON MAC

I am using InVEST 3.3.3 SDR, WY and NDR on my windows desktop but i want to use same on my Mac and looking for a way to install it.
Macbook Pro 10.14.5. Any link or direction would b appreciated please.
Thank you.
Regards,
Amy

Hi Amy,

InVEST 3.3.3 is pretty old! I’d strongly recommend updating to the latest versions if you can, as we’re constantly improving how the models work.

If you do need to find a copy of 3.3.3, however, you’ll find older versions of InVEST at http://data.naturalcapitalproject.org/invest-releases/.

Dear James,

Thank you so much for the quick response. If you say so then I will up grade, was scared of getting different results since I have been using the old version and I fear having to learn new way of using recent version too.

Could you share the link and possibly direct on how to install both on my Mac?

Thank you again.

Regards,

Amarachi

Hi Amy,

Depending on the models you’re using, there’s always a chance that upgrading will change the results. SDR and NDR in particular do have major updates to routing, for example, in InVEST 3.7.0. But if you can, we always recommend using the latest versions of InVEST to take advantage of the latest bugfixes and enhancements, and you’ll need to use the latest versions anyways to be able to use new InVEST models.

If you need to use multiple versions (maybe you’re using 3.3.3 for a specific analysis and need to keep it around but you also want to use 3.7.0), there’s no problem with having both versions of InVEST on your computer at the same time.

For mac installation instructions, please review the User’s Guide section on mac installation: http://releases.naturalcapitalproject.org/invest-userguide/latest/getting_started.html#installing-invest-and-sample-data-on-your-mac and feel free to post back here if you have any questions. It does look like InVEST 3.3.3 won’t run on your mac, though, due to a security feature introduced in Mac OSX 10.13 that wasn’t working with how we were building InVEST at the time, so the oldest version of InVEST you’ll be able to use on your mac will be InVEST 3.4.0.

Hope this helps,
James

1 Like