Understanding Carbon Results and QGIS questions

Hello everyone,

I’m performing a carbon analysis for a province in Indonesia. I’m not sure whether my output is correct. Can anybody help me? I attach here the carbon pools excel file + the LULC shapefile I used + the output’s text document. I also attach a screen of my outputs in QGIS.

Furthermore, I have two QGIS-related questions:

  1. for the InVEST analysis do I have to set a specific CRS?
  2. How can I merge a LULC raster file with a vector file (roads)

Thank you!!

InVEST-InVEST-Carbon-Model-log-2020-03-10–23_14_41.txt (4.6 KB) carbon_pools_MG.csv (454 Bytes)

I cannot upload the shapefilie

Hi @marco.guzzetti -

Yes, you need to have your spatial inputs in the same projected coordinate system, where the units are in meters (see the User Guide Data Needs section for more information.) The model uses the area of each cell, along with the carbon pool values (which are Mg C/hectare) to calculate carbon storage. I am guessing that your land use map has a geographic coordinate system, where the units are in degrees, which is causing those very small output values.

There are probably several ways of merging rasters with vectors, but the way I just did the same thing is to turn my vector file into a raster, with the same cell size as the LULC, then use Raster Calculator to combine the two. In ArcGIS I use the Con tool for this, I’m not sure what the equivalent is in QGIS.

~ Stacie

Hello @swolny,

Thank you for your reply. I set the same CRS (EPGS: 3857) for both my inputs and project.

However, the result is always the same.

What do you think is the problem?

Again, thank you!


Hi Marco -

Since the log file doesn’t show anything wrong, and your carbon pool table looks fine (thanks for posting those!), it’s not obvious what’s happening. One thing is that I believe the underlying libraries don’t support Web Mercator, and I know yours isn’t exactly that, but I’d try reprojecting to a different coordinate system (UTM is a safe choice, and a lot of others work too) and see if that changes anything.

~ Stacie

Dear Swolny,

thank you so much for your help. I tried to use some different CS but nothing has changed.

I wonder if InVEST can work if I use QGIS to prepare the inputs required. Anyway, do you have any other suggestions?

Again, thank you for your time.


You can use any GIS you want to prepare the inputs. I often mix the two, doing most things in ArcGIS, but filling my DEM in QGIS. Other NatCappers work exclusively in QGIS.

If you can send me your data, I’ll check it out. You can post a link here or send it to swolny at stanford.edu.

~ Stacie

[quote=“swolny, post:7, topic:872”]

Thank you Stacie, I’ll send you my files!


Thanks, Marco. I just ran InVEST 3.7 Carbon with the data you sent, and got the kind of values you’d expect (0 - 1476 MgC/pixel.) Everything looks good in terms of coordinate system and units in your inputs. Just in case, I looked at the result in both ArcGIS and QGIS and it looked fine in both, I am not seeing the e-07 values that you are.

So I’m not sure what’s happening on your end. Have you played with the raster symbology for tot_c_cur, in case it’s just a symbology issue? If you use the Identify tool and click around the raster, do the pixels have reasonable values? What’s the min/max in the raster properties?

Sorry, but I’m not sure what else to do to help since I can’t replicate the issue.

~ Stacie

1 Like

Dear Stacie.

Thank you so much for your help! It was very helpful.

I wish you a very nice day!


I changed the CRS and I obtained the same values. So I think that now it is working

I’m surprised to hear that was necessary, since the previous CRS worked for me, but glad that it’s now working for you. Thanks for letting us know, Marco.

~ Stacie

S’il vous plait, les rasters qui sont à soumettre à InVest doivent contenir quelles informations?
Est ce que ça doit contenir les informations du pool de carbone? Merci.

@swolny I also had a problem with my values. I assigned values for my land cover map with number from (1-25) and I assigned the carbon storage values to the land cover numbers. However, the result was all over the place. For example water was supposed to be zero but I got the values of open wetlands, the settlement values became zero. I tried to check my excel file but it was correct, and I did not get any error when I ran the model. I also checked my land cover map and it was assigned correctly

The rasters used in the InVEST Carbon Storage and Sequestration model are described in the user’s guide, which can be found here: Carbon Storage and Sequestration — InVEST documentation

I hope you find all the information you need there, but feel free to write back to us if you have questions.

Hmm, this sounds very strange and unexpected. Could you upload your logfile so we can start taking a closer look? Thanks.

InVEST-Carbon-Storage-and-Sequestration-log-2022-04-29–10_54_14.txt (5.1 KB)

OK, I don’t see anything strange going on in the logfile. Would you please share your input LULC and biophysical table?


tot_c_cur_gavle.tif (253.2 KB)
carbon_storage_2016.csv (1.4 KB)

Thanks for sending your biophysical table, but would you please include your LULC raster? This would be Gävle_city_LULC.tif.