Errors in running urban cooling model

Hi urban cooling users and developers,
I am attempting to run the urban cooling model at a city-wide level. About 8 minutes into the model run, the run stops and generates the following error:

2023-06-20 17:08:30,437 (shapely.geos) geos.callback(289) ERROR bad allocation
2023-06-20 17:08:30,446 (shapely.geos) geos.callback(289) ERROR bad allocation
2023-06-20 17:08:30,446 (taskgraph.Task) Task.add_task(706) ERROR Something went wrong when adding task pickle cc ref stats (14), terminating taskgraph.

Traceback (most recent call last):
File “shapely\”, line 15, in call
File “shapely\”, line 602, in errcheck_predicate
shapely.errors.PredicateError: Failed to evaluate <_FuncPtr object at 0x0000016837F5F1D0>

The model does run for me when I use a highly-simplified, i.e., 7-category LULC map without the individual city parcels. This file has 250K entries. Could that be the problem? And if so, should I clip the file to the neighborhoods of interest to be cooled?
Thank you in advance for your help.

Full output log attached here: InVEST-natcap.invest.urban_cooling_model-log-2023-06-20–16_59_46.txt|attachment](upload://uQmWuEqcLQHf0dzdYsSOjRpCBqG.txt) (30.6 KB)

@lptomasso it appears that your log file did not upload correctly, can you please try attaching it again?

Thanks for your attention to my issue here. I’ve reuploaded the log file and will also resend it as an attachment to your email in case it doesn’t open here.

InVEST-natcap.invest.urban_cooling_model-log-2023-06-20–16_59_46.txt (30.6 KB)

Hi Emily,

Thank you for catching my post on the Community Forum and for giving it your attention to help me resolve my Urban Cooling modeling. I reuploaded the log file on the forum site but am also attaching here in case it isn’t retreavable on the site. I have used the InVEST carbon sequestration and blue carbon models in the past with success and am looking forward to applying this new module to nature-based solution projects I’m working on here at Harvard.

Thanks again,

InVEST-natcap.invest.urban_cooling_model-log-2023-06-20–16_59_46.txt (30.6 KB)

Thanks for attaching your log file. I think this error is happening because your AOI vector contains one or more invalid geometries. I would try checking your AOI for invalid geometries (such as using the “Check Validity” tool in QGIS, for example) and repairing any that you find. Let me know if that helps!

Hi Emily,

Still no luck after repairing the geometries on my input file. Attached here is the new output log file, which generated immediate errors. I am not a seasoned ArcGIS user but can execute the basic tools in the Toolbox. Perhaps you can detect from this log file what errors I am making to compound my problem.

Thanks so much.

InVEST-natcap.invest.urban_cooling_model-log-2023-07-11–14_01_28.txt (6.84 KB)

Now it looks like your LULC raster is corrupted. See the error:

The following 15710 raster values
[ 72 81 85 … 267559 267563 267565]
from “C:\Users\tomas\Documents\ArcGIS Pro 3.1\Springfield_Cooling\Results\Full Springfield\intermediate\lulc.tif”
do not have corresponding entries in the value map: {0: 0.0, 1: 0.0, 2: 0.37, 3: 0.55, 4: 0.76, 5: 0.93, 6: 0.7, 7: 1.0, 8: 1.0, 9: 1.0, 10: 1.0, 11: 1.0, 12: 1.0, 13: 1.0, 14: 1.0, 15: 1.0, 16: 1.0, 17: 1.0, 18: 1.0, 19: 0.0, 20: 0.3, 21: 1.0, 22: 1.0, 23: 1.0, 24: 1.0, 25: 1.0}.

I doubt that your LULC raster is supposed to have 15,710 unique LULC codes! Please check your LULC raster and make sure that it looks correct.

Ugh. Thank you for your quick and efficient feedback. I wish I were more skilled at ArcGIS, but this project is important that I understand my errors and execute the InVEST urban cooling model correctly!

I’ll let you know how I fare, Emily.

Hi Emily,

This is a check-in to let you know I am making no progress and seem to get more confused with every run of my input files on the cooling model. Do you recommend that I try to trouble-shoot directly with you or through an alternative route? I am thoroughly discouraged, as I can run the model as a proof of concept for the entire city, but not with disaggregated LULC parcels as I need to do.

Thank you for your patience.

If you’ve checked that all your inputs meet the specifications outlined in the user’s guide, and you’ve searched the forum for solutions to your error messages, and the problem is still not solved, you can upload your data and we’ll take a look at it. Instructions for attaching your data are here: An easy way to share data using the InVEST Workbench

Hi Emily,

I seem to have had some better luck today with running the urban cooling model and wanted to ask if my output adheres to expectations. I wanted to share the map itself, but somehow the data layer is inaccessible. I’ve attached the output file, and here is the screenshot to the ArcGIS map below:

  1. Does this look like an accurate output based on baseline LULC parameters?
  2. How should I interpret each of the black/white layers in the Contents in terms of cooling effect? note also that the uh.results file is the only one which corresponds to the State of MA tile covering part of Springfield and not my clipped city borders. I don’t know what this is.
    If you prefer I address this on the Forum, happy to do so. Thank you.

InVEST-natcap.invest.urban_cooling_model-log-2023-07-13–12_19_00.txt (17.4 KB)

Just returning to my question of result interpretation for the InVEST urban cooling model when one of your developers has time. Thank you!

Hello @lptomasso,

Could you elaborate on which layer is inaccessible? I can’t tell just from the screenshot.

As far as your logfile goes, it does look like there was an issue when the model was computing zonal statistics over the T_air.tif model output (you can see the ERROR messages in your logfile), so you could try re-running the model to see if that corrects the issue. But aside from that, the ranges that ArcPro is symbolizing look fine to me. Is there a specific issue with your model outputs that you are concerned about?


Hi James,
Thanks you for this quick attention to my model output and for pointing out what’s going wrong and what surprisingly went right.

The inaccessible model layer is coded “00003 Layer’s data source is inaccessible.” I’m not sure what that refers to.

Also, you’ve accurately pointed out that the T_air.tif model output is not correct. I did try to run again (accepting that I am not a modeler), and it gave out the same result. Attached is the output file if you can detect the error within.

Finally, can I confirm with you that as a next step to simulate nature-based changes to mitigate heat, I would simply substitute things like albedo values in the bio-physical table for paving surfaces or manipulate the LULC code in the land cover map, foresting parking lots, for example? This is what makes this model particularly useful and I want to take full advantage of its potential.

Thank you again for any feedback.

InVEST-natcap.invest.urban_cooling_model-log-2023-07-19–14_02_54.txt (17.3 KB)

Hi @lptomasso -

The error “Layer’s data source is inaccessible” is coming from ArcGIS, not InVEST. It looks like you’re trying to make an ArcPro Package of your map session, and it can’t find the data underlying one of the layers, so can’t add it to the package. We can’t troubleshoot that, you’ll need to figure out which layer it’s complaining about and either remove it or point the layer to valid data.

~ Stacie

1 Like

Very clear explanation, Stacie. There is so much to master here, and I’ll check that internally. I appreciate your quick reply.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.