Workbench does not run after startup

new post:

Hi James I’m a newbie to the software and needed to check my windows 10 install as I can’t seem to get it running. version 3.14.1. I have downloaded and installed the software but it doesn’t run after start up.

@frederick , I moved your post to a new topic since it’s likely to get lost if attached to a two-year old thread.

Can you describe in any more detail what happens? I assume you click the “InVEST 3.14.1 Workbench” link from your start menu…and then what happens?

Could you look at the Windows Task Manager when you do this to see if the Workbench appears in the “Apps” list?

Also, please check if you have any files in this folder and upload them here:
C:\Users\<your username>\AppData\Roaming\invest-workbench\logs

Thank you,

Hi there, thanks for the reply seems to be working now.

Hey Dave I seem to still be having trouble running the workbench. any advise? Maybe I spoke too soon.

Please follow the advice I posted in my first response.

[13:54:38.366] [C:\Users\User\AppData\Local\Programs\InVEST 3.14.1 Workbench\resources\app.asar\build\main\main.js] FetchError: request to http://127.0.0.1:56789/api/ready failed, reason: connect ECONNREFUSED 127.0.0.1:56789
at ClientRequest. (C:\Users\User\AppData\Local\Programs\InVEST 3.14.1 Workbench\resources\app.asar\node_modules\node-fetch\lib\index.js:1505:11)
at ClientRequest.emit (node:events:513:28)
at Socket.socketErrorListener (node:_http_client:502:9)
at Socket.emit (node:events:513:28)
at emitErrorNT (node:internal/streams/destroy:151:8)
at emitErrorCloseNT (node:internal/streams/destroy:116:3)
at process.processTicksAndRejections (node:internal/process/task_queues:82:21)

Hi Dave have attached sample log previews of what’s going on with the software

Thanks, it would be most helpful if you could upload the whole file for all files you find in,
C:\Users\<your username>\AppData\Roaming\invest-workbench\logs

Use the “upload” button when replying here to attach the files. If you tried that previously and it didn’t work, I have adjusted some settings here so hopefully it will work if you try again. Thanks.

In addition, I would exit the Workbench and then check your Windows Task Manager to see if there are any processes still running called,

“InVEST 3.14.1 Workbench”
“invest-workbench”
“invest.exe”

Force quit or “End Task” any that you find. Then try starting the Workbench again.

Thank you,

Thank you Dave here’s what’s there.

main.log (203.2 KB)

Hi @frederick , thanks for sharing your logfile. Sorry I haven’t been able to respond earlier.

From the log, it appears that most of the time the Workbench does not startup correctly, but that maybe it has started correctly once or twice?

One of the startup operations is taking much longer than expected and it ultimately times out. I’m not sure what is causing that. We might try changing a few things and sending you a new version to try, though that might take a few more days.

In the meantime, if you feel like trying something, you could do the following:

  1. Make sure the Workbench is closed
  2. Open the “Command Prompt” program on Windows
  3. Copy/Paste this command and press enter:
"C:\Users\User\AppData\Local\Programs\InVEST 3.14.1 Workbench\resources\invest\invest.exe" serve --port 56789
  1. Wait for a message like this to appear in the command prompt (I’m curious how long this takes if you try it):
 * Serving Flask app 'natcap.invest.ui_server'
 * Debug mode: off
WARNING: This is a development server. Do not use it in a production deployment. Use a production WSGI server instead.
 * Running on http://127.0.0.1:56789
Press CTRL+C to quit
  1. Open the Workbench, try running a model
  2. When you are done and after you have closed the Workbench, you will need to go back to that Command Prompt window and press CTRL+C to exit that invest server program. Or you can leave it running.

Thanks again for reporting this problem. It is certainly something we would like to resolve.

thanks dave got it working. stellar stuff.

Great to hear! Did you have to wait long for that “Serving Flask app” message to appear after entering the command in the terminal? That’s the step that seems like it takes way too long during the Workbench startup, based on your logfile.

not that I remember. I haven’t shut the command prompt yet but if it’s likely I’ll have to run the command again
. Ill keep a look out.