Attribute table - Carbon model

After running the invest model, on opening the output map in ArcGIS, the attribute table is not visible.

I tried building the attribute table in through the tools, but then it shows error "

ERROR 000423

Only single band integer raster dataset is a valid input"

Pl let me know how to proceed in order to view the results.


Hi @priyasharma , it sounds like you’re viewing one of the raster outputs? The rasters produced by InVEST don’t have attribute tables. All the results are stored in the raster pixel values. A summary of those values is provided in report_*.html which you can open in a web browser. I hope that helps!

Interestingly, there’s a parallel conversation about how to generate raster statistics from a floating-point raster over at Is there any method to make attribute table? that you might find interesting.

1 Like

thank you for the help @dave. I am able to see the desired output in the html file.
But I am still confused, how to present and interpret the results from the map. This is an example of how I want to present my results

. How to decide the ranges ?

Hello @jdouglass i tried creating the attribute table in this way. But the fields in the table does not match with the fields as listed in the excel sheet with the carbon pool data. T

Your GIS software can probably help you try different ranges. The “Symbology” menu for the raster might include different options for ranges like “equal interval”, “quantiles”, “stretched”, and others. There’s often no right or wrong answer when deciding exactly what the ranges should be.

@priyasharma Were you able to resolve this, or are you still seeing this inconsistency?