Carbon Sequestration and Storage - Dataset must be projected in linear units


I am working with the Carbon Storage and Sequestration model. Before running the model I get an error in the current Land Use/Land Cover Raster that says “Dataset must be projected in linear units”. My data is projected in EPSG:6363 Mexico ITRF2008. As far as I know that has linear units. Can you help me sort this out? Which CRS should I use for the raster to be in linear units then?
Thanks in advance
Alejandro León

Link to the raster file.

Hi @leonale , thanks for sharing your data. This is a bit strange. Here’s what I see for the projection info on this raster (from gdalinfo):

Driver: GTiff/GeoTIFF
Files: Current_Raster1.tif
Size is 9390, 12560
Coordinate System is:
GEODCRS["Mexico ITRF2008",
    DATUM["Mexico ITRF2008",
        ELLIPSOID["GRS 1980",6378137,298.257222101004,
Data axis to CRS axis mapping: 1,2,3
Origin = (-90.085700000000003,20.209299999999999)
Pixel Size = (0.000100000000000,-0.000100000000000)
Image Structure Metadata:
Corner Coordinates:
Upper Left  ( -90.0857000,  20.2093000) (167d21'21.36"E, 90d 0' 0.00"N)
Lower Left  ( -90.0857000,  18.9533000) (168d 7' 7.38"E, 90d 0' 0.00"N)
Upper Right ( -89.1467000,  20.2093000) (167d13'37.55"E, 90d 0' 0.00"N)
Lower Right ( -89.1467000,  18.9533000) (167d59'49.85"E, 90d 0' 0.00"N)
Center      ( -89.6162000,  19.5813000) (167d40'28.15"E, 90d 0' 0.00"N)
Band 1 Block=9390x1 Type=Float32, ColorInterp=Gray
  NoData Value=0

It does list metre as the linear unit, and that should be just fine. But the other places where we can see the actual coordinates in this raster (Origin, Pixel Size, Current Coordinates) all show values that are probably decimal degrees instead of meters. So that makes me think this raster was not correctly projected to the Mexico ITRF system, but was incorrectly assigned/defined to that system without actually being projected/transformed. Does that make sense?

1 Like

It was originally projected in WSG84, I used the warp tool in QGIS to change the CRS. Do you have any recommendations on how to solve this?

Well that sounds like a reasonable approach. I’m not sure what could have gone wrong there. I usually use the Layer > Save As... menu to warp a raster, but that should be no different from using the Warp tool.

If you would like to share the original wgs84 raster I can try to reproduce the problem.

I have tried that as well but it doesn’t seem to be working either. I generated the data again and it is still happening. The following link leads to a newly generated raster with no set CRS. Even like that it doesn’t work. Current_Raster4.tif - Google Drive

This “Current_Raster4.tif” looks like it has the same CRS as the first one you shared. Can you link me to the original wgs84 data source?

This must be it then. Current_Raster6(WSG84).tif - Google Drive

Got it, thank you. I had slightly different results than you warping to epsg 6363, but it still did not work properly and I think it must be because that CRS uses geocentric coordinates. It seems like geocentric projections might not be well supported by the library that QGIS & invest use to handle projections. Also a geocentric system is probably not ideal anyway since it includes a Z-axis which will just be ignored.

I recommend a UTM system. Not knowing precisely where your study area is, I tried epsg 6368 and it seemed to work well.


The zone fits better to epsg 6370. I warped to that and its working. Thanks for the support!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.