How to deal with the error message "Dataset must be projected in linear units."?

As a novice of InVEST 3.8.0 , I am using the water supply model for my undergraduate dissertation. When I entered raster data like land use, precipitation, and soil properties. I got the error message “Dataset must be projected in linear units.”
Does anyone know how to solve this situation?I sincerely need your help!
Thanks very much!

Hi @angelczl -

That message means that the spatial layers must have a projected coordinate system assigned, with linear units like meters. It is likely that the inputs that you provided have a geographic coordinate system (like WGS84), where the units are in degrees.

The model requires that all spatial inputs be in exactly the same projected coordinate system, with linear units in meters. Please see the User Guide for a further description of the requirements. Try doing a Reproject (ArcGIS) or Warp (QGIS) on your layers to give them the same projected coordinate system, try running the model again and let us know how it goes.

~ Stacie

Hello @swolny
Fristly, I really appreciate your help for your answer, which really helps me a lot!
I checked that the input either didn’t have projected coordinate system or have geographic coordinate system like WGS84 just as you said. I defined the projected coordinate system with ArcGIS and than the model can run.
Unfortunately the new problem appears. I got the error message “Bounding boxes do not intersect” when I ran the model. I tried to do the geographic registration and spatial correction for the input data,but the model still can’t work normally. This error message appeared again.
Do you know how to deal with this situation?
Thanks very much!
~zl Chen

I’m concerned that in this step you “re-defined” a coordinate system instead of actually “re-projecting” it as Stacie suggested. If that is the case then you may need to go back to your original data, and try “reprojecting” the datasets that are in a geographic coordinate system, so that they end up in a projected coordinate system.

Thank you for your reminding, Dava. I edited the attributes of the raster data directly from the list of directory files and modified the projected coordinate system.As you said, maybe I have made such a mistake.

To change the coordinate system, you need to use the tool Reproject in ArcGIS or Warp in QGIS. If you only edit the raster attributes, you are not actually reprojecting the raster so it has new coordinate system. You are only giving the same coordinate system a new name, and now that name does not match the actual coordinate system of the raster. It’s a bit confusing. But I advise going back to the original dataset (before you edited the attribute table) and use Reproject or Warp. Make sure that you give all of your layers the same projected coordinate system (so the units are in meters, not degrees.)

~ Stacie

Thank you all for your help, I used the tool Project Raster in ArcGIS and changed the projected coordinate system. Then the extent of data were changed to nearly the same.
The model ran successfully,which encouraged me a lot!
Thanks again!

2 Likes

Yay! Glad to hear it, @angelczl. Thanks for letting us know.

~ Stacie