Error in carbon model

Hello! I have a problem when I want to run the carbon model.
The caption reads like this: UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xf3 in position 105: invalid continuation byte

Somebody could help me?

Hi @CamilaMujica -

Did the model produce a log file in your Workspace? If so, please post the whole thing here.

It would also be useful if you can post the carbon pool table, since I’m guessing that this error is related to it. Thanks.

~ Stacie

Hi Stacy!

Yes, the model produced a log file.

I share this with you, and I also share with you the carbon pool table I used.

Thank you very much for your help

InVEST-natcap.invest.carbon-log-2022-11-09–10_57_27.txt (14.9 KB)
Tabla_CVS.csv (149 Bytes)

Hi @CamilaMujica -

One thing I see is that Tabla_CVS.csv has values that are separated by semicolons, but the model requires that values be separated by commas. I’m not sure if this is causing the error, but I recommend saving the table with commas as separators (if you’re using Excel, save it as type “CSV (comma delimited)”) and see if that helps.

If you still get the error, it might be a problem with the land use raster, not the table. In that case, you can send me the raster and I’ll take a look at it too. Send it to Thanks.

~ Stacie

Thank you very much for the reply. However, the error continues. I will send you the raster and the CSV table shortly by mail. I hope we can find the solution.
Thank you very much again!

@CamilaMujica thanks for sending your input data. I have no problem running the Carbon model with these inputs, using InVEST Workbench 3.12.0. No error is produced and the output looks ok to me, so I’m not sure what’s happening to cause the error when you run it. One thing I wonder is if your E: drive is a local disk, or somewhere out on the cloud. If it is on the cloud, you could try copying your data to a local disk and see if that fixes the problem.

One thing that is unusual about your raster is that the pixels are not square, so I would recommend resampling them to a square size. But I don’t think that should cause issues for this model, and it doesn’t produce an error when I run it.

~ Stacie

1 Like

Hi Stacey!

I have tried all options and to no avail. I finally installed the software on another computer and was able to run the model without any problems.
I will never know what happened, but the important thing is that it was solved.

I really appreciate all your help

Greetings from Argentina

I’m glad that you found a workaround @CamilaMujica, even if the cause will remain a mystery.

~ Stacie