GLOBIO unexpected output


I’ve managed to run the GLOBIO model successfully and all the msa_x_ outputs look fine except for the msa_i_ file. Below is a screenshot of the msa_i_ output I generate.

The intermediate output for distance from infrastructure comes out blank too with a zero value. I’ve tried using both raster and vector layers in the input infrastructure directory folder but the outcome remains the same. I’ve attached the log report below. Would appreciate some help.

InVEST-GLOBIO-log-2020-05-04–14_35_10.txt (13.7 KB)

Hi @KarenL,

Thanks for posting about this issue. Would you be will to share your input data to help us debug this for you? Depending on the file sizes it could be uploaded here or shared via google drive, dropbox, or email. My email is



Hi @KarenL

When looking through some of your inputs I noticed that the pasture input raster was all 0 values with large no data holes. I also noticed that the potential vegetation raster was all 1 values except for a small nodata hole.

I’m trying to bring myself up to speed on the model, but wanted to make sure that those inputs were intended.


Hi @KarenL

There appears to be a bug in the GLOBIO model with how the infrastructure nodata values is handled. Could you try setting your infrastructure raster to have a nodata value of -1? I think that might work around the issue I’m seeing now, which could be causing the issues.



Hi Doug,

I’ve done that and the final MSA infra layer still remains blank although the intermediate output for the distance to infra comes up fine, which is definitely an improvement.

I’m actually using the GLOBIO in an urban setting so I’m not sure if that could potentially explain the odd output but I am going to try changing the values in the MSA parameter table for a local, urban species (if i can get that information) and see how that goes. Do you think it’d be worth a try?


Hi @KarenL,

I was able to patch the issue I mentioned above and continued the run using your data but also got more bad results. Upon further digging it looks like this set of data hits on a bug in a convolution function that we fixed a week ago, but that patch is living in our latest geoprocessing release which we are in the middle of getting into InVEST… All to say I’m not certain that changing the values in the MSA parameter table would help.

I’ve attached a file that shows the bug. The outline around that smoothed raster should not be there, and we definitely should not have negative values.

We’re actively working on getting this issue taken care of and I will respond back here when I have a new version of the model for you to try. Sorry about the inconvenience and thanks for helping us make InVEST better!

Following up on this topic as I never actually uploaded a file to show the bug!

The fix for this convolution issue is done and the uptake into InVEST is actively being developed.

Hello I am having the same problem with Invest 3.8.6 and 5. Did you manage to fix this bug? would love to be helped.



Hi @cparrapa ,
It looks like the fix for this issue actually wasn’t added until InVEST 3.8.7, the latest version. Could you please try downloading version 3.8.7 and running the model again? Let me know if the problem still happens!


1 Like

Hi Emily,
Thanks for replying. I tried this but I was not even able to make the globio interface to work (3.8.7)…I tried to install it several times but it did not work. Any idea on how to fix this?

Hi @cparrapa ,

Are you able to run the model at all? If so, there should be a log file that would help me identify the problem. If not, could you please share a screenshot of what isn’t working with the interface? I’m sorry for the trouble!


Hi @esoth

I am not able to run the model at all. The installation seems successful but when I try to open the GLOBIO application, the interface (where I should upload the input files) does not appear (only the black window appears). I attach the loginstall_log.txt (97.5 KB) file of the installation.

Hope this helps to get your help


When you say that ‘only the black window appears’, does the window show up briefly and then disappear? Or does the window stay open for a long time, just without the main window not showing up? Let us know!

The window stays there for long time without displaying later the interface.

OK, great, thanks for clarifying. Could you attach the text file found at C:\Users\<your username>\AppData\Roaming\Natural Capital Project\GLOBIO.ini to this thread (or send it to me some other way)? This file contains the parameters that the model is trying to read and validate on startup, and the validation can take a long time under certain circumstances. It’ll be helpful for us to see what those paths are in case there’s something happening because of where the files are located on your computer.

GLOBIO.txt (672 Bytes)

@jdouglass here you have it…It is weird because for other invest versions it works smoothly and fast…

Ah, thanks! This is really helpful.

So, it looks like several of your inputs are pointing to files or folders located in your SURFdrive (which looks like a cloud storage service). Lots of cloud storage services (including Google Drive’s File Stream and Dropbox’s native applications) minimize the amount of local disk space they use by only loading the files they need when they are needed. That’s great for most use cases, but it doesn’t work very well for InVEST.

One of the things that the InVEST user interface is doing when it opens a model window is that it validates the set of inputs from your last run. So for files that are in your SURFdrive, that means that the file needs to be downloaded first, which can take a long time. I suspect that if you were to just leave the InVEST application alone for a while, the UI would probably eventually load up, but it could take quite a while!

In the short term, you can delete the GLOBIO.ini file that I pointed you to. The UI should start up very quickly (and let us know if it doesn’t).

And in the longer-term, I would advise you to download whatever files you need from your SURFdrive, from Google Drive, or Dropbox, or whatever cloud storage service you might be using, before you run InVEST. Oh, and I also see that your workspace is pointing to a folder in your SURFdrive as well … this is also likely to cause problems down the road. Instead, be sure to select a folder on your local computer that is not automatically backed up by a file sharing service.

Let us know how this goes!

1 Like


I deleted GLOBIO.ini and it didn’t work. I will do as you say with my file directories in the future. For some reason the application is not running yet…why that can be? I thought uninstalling and installing again would help but not at all…


Well, I’m not 100% sure what’s going on, but let’s see if we can find the issue together! Here are a couple of things that are worth trying:

  1. What happens when you disable your network connection?
  2. What happens when you delete the whole folder at C:\Users\<your username>\AppData\Roaming\Natural Capital Project\?
  3. Could you try the steps below and let us know which lines of the logging the UI appears to be hanging on?
    • Open cmd.exe
    • type cd C:\InVEST_3.8.7_x86\invest-3-x86
    • type .\invest.exe --debug run globio (this will run the model and also print a lot of debug logging to the console). I’m especially interested in any lines that the model is stopping on.

Hello again @jdouglass and thanks a lot for helping me out

I tried all the options. For 1 and 2, nothing change, the interface did not appear. I did 3 but did not get any line…where are they suppossed to be shown?

I guess trying in another computer will be a faster solution? or how can I install everything from scratch again?..would that help to get rid of the problem (since I was able to run version 3.8.6 in first place without problem. Then I installed 3.8.7 that did not work and then I tried 3.8.5 which did work.