Habitat quality result

What is the issue or question you have?

The result of running the entire model at the end does not find the threat raster but always the first threat of the threat table

What do you expect to happen?

That I give the result of habitat quality for that coverage of the first threat

What have you tried so far?

Change the order of threats in excel but the same always the same threat omits the assessment of the habitat for that threat

Attach the logfile here:

Hello @Italo25 and welcome to the forums! Could you attach the complete logfile here from your model run so we can take a closer look? It will be a .txt file in your output workspace.


Uploading: InVEST-natcap.invest.habitat_quality-log-2023-06-09–15_13_16.txt…
Hello how is this if of course I send the final output file in text.

InVEST-natcap.invest.habitat_quality-log-2023-06-09–15_13_16.txt (10.1 KB)

Thanks for including your logfile! There’s a line in the logfile that is probably why you’re not seeing many outputs:

WARNING The threat raster for pastizal could not be found for the land cover _b. Skipping Habitat Quality calculation for this land cover.

So what that means here is that the raster past_c.tif could not be found, which then means that the whole habitat quality calculation is skipped. You’ll also want to make sure that po_c.tif and all of the other rasters listed in your CUR_PATH column are in the same directory as your threats table. Once the rasters are all there in the same directory as your threats table, you should be able to run the model past this issue.

Let us know if you run into any other problems!

InVEST-natcap.invest.habitat_quality-log-2023-06-15–00_39_05.txt (34.6 KB)
As this a pleasure thanks but, I do not find anything is more use the example that gives the InVEST and even so it gives me error, nose that happens the truth I reinstalled the program but even so I get the same error. Attached text from the InVEST example for habitat quality. I hope you can help me please.

Hi @Italo25 -

The log file indicates that the model ran successfully, I don’t see any error messages. Look at the output files in a GIS and see if they look ok.

~ Stacie

Hello as this, I get this result always for the first threat

Hi @Italo25,

The reason that warning is happening with the sample data is because we do not provide threat raster data for a baseline scenario. You’ll notice in the sample data that there are threat rasters ending in _c.tif and _f.tif, but none ending in _b.tif. If no threat rasters are found for the baseline (or future) schenario then they are skipped.

So, if you remove the baseline land use land cover raster from the model, that warning will go away.



Good afternoon, yes but in the first image I send to me I also get the same error and I use a reference map, of course when removing the reference layer the error does not appear but I need to remove the rarity of habitat, so I do not know that it is wrong and because the value of the first threat is omitted, then my question is if I have to also perform threat raster for base coverage, I hope an answer thanks

Hi @Italo25,

Sorry that we haven’t been able to clear up the confusion. That red text in the log output is a Warning, not an error, meaning the model still ran okay. That Warning is to let the user know that no threat rasters were found for the Baseline scenario, so Habitat Quality for the Baseline scenario will not be calculated. However, Habitat Rarity should still be calculated regardless. Habitat Rarity is only dependent on a Baseline LULC and Current / Future LULC.

If this doesn’t quite clear things up would you mind zipping up and sharing your input data so we can better get a sense for what we might be missing.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.