HabitatQuality - error encountered in threats table/threats distribution map

I am trying to run a simple example with the HabitatQuality model, but I do not succeed. Enclosed is the run log-file, my LULC_current, current threats distribution map and the threats and sensitivity tables. I hope this is sufficient to bring me a step further.
InVEST-natcap.invest.habitat_quality-log-2022-02-02–13_38_21.txt (5.6 KB)
LULC_current_Opeland.tif (5.0 KB)

Opeland_crops_c.tif (17.9 KB)
Sensitivity_table_opeland1.csv (347 Bytes)
Threats_table_opeland.csv (145 Bytes)

Best regards

Thanks for the log and data @Kaare. I just looked at both of them, ran them through InVEST and don’t understand what’s going on. I see two things in the log file:

WARNING Raster has undefined NODATA value for C:\Users\Bruker\OneDrive\ES_run\InVEST_og_QGIS\InVEST_HabitatQuality_kjoringer\Opeland\NatCap_Community_sending\opeland_crops_c.tif


ValueError: (‘C:\Users\Bruker\OneDrive\ES_run\InVEST_og_QGIS\InVEST_HabitatQuality_kjoringer\Opeland\intermediate\opeland_crops_c_aligned.tif’, 1) has a row blocksize which can make this function run very slow, create a square blocksize using warp_raster or align_and_resize_raster_stack which creates square blocksizes by default

Looking at the rasters’ cell sizes, they appear to be square (10x10), so I’m not sure what “blocksize” the error is talking about. The intermediate file opeland_crops_c_aligned.tif also appears to have a 10x10 cell size. For the heck of it, I tried running Arc’s Resample, outputting at 10m cell size, and that didn’t help.

It is true that both of the raster inputs do not have NoData set (Kåre, they do need to have a value set for NoData), so I tried setting that and it didn’t help.

Can someone in the software team take a look at this? Thanks!

~ Stacie

Thanks Stacie for your numerous efforts to bring forth a solution. I really appreciate that.


Hi @Kaare , I believe I’ve found the issue. There is indeed a bug in the Habitat Quality model just before the convolution. I’m working on a fix and will send you a development build soon, probably within the next day.


Thanks very much for your immediate respons.


Hi @Kaare , could you try this development build and verify that it fixes the issue?


You may need to delete your workspace directory before running the model.


Working! Thanks.


Great, thanks for checking out the dev build! We’ll see that this fix is in our next bugfix release.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.