InVEST Carbon model

Dear sir, madam
I’m running InVEST Carbon model version 3.5.0 and getting this error: ValueError encountered: bins must be monotonically increasing or decreasing. What should i do for correct this error.
This is my carbon pools data.

C_above C_below C_soil C_dead lucode LULC_Name
0 0 0 0 0 Built Up area
0 0 0 0 1 Canal- Wide
3 2 8 1 2 Chena
0 0 0 0 3 Ela
140 70 35 12 4 Forest
5 5 15 2 5 Garden
15 35 30 4 6 Grassland
3 2 10 0 7 Other plantation
10 5 20 0 8 Paddy
0 0 0 0 9 River
80 50 100 25 10 Rubber
30 30 30 13 11 Scrub
0 0 0 0 12 Tank with Bund
0 0 0 0 13 Tea
0 0 0 0 14 Water Hole

Hi @Nayanathara -

First, can you try using the latest InVEST, version 3.7? That has a lot of bug fixes since 3.5, and this problem might go away. If you still get the error, let us know - thanks!

~ Stacie

I;m running InVEST Carbon model 3.7 version, but output map didn’t display and carbon storage value was missing in the output report. I obtained results was given below.
This document summarizes the results fromrunning the InVEST carbon model with the following data.

Report generated at 2019-06-11 18:59

arg id arg value
calc_sequestration False
n_workers -1
results_suffix
do_redd False
workspace_dir C:\Users\user\Documents\carbon_workspace
lulc_cur_path C:/Users/user/Desktop/Sanuka/this.tif
carbon_pools_path C:/Users/user/Desktop/LULC.csv
do_valuation False

Aggregate Results

Description Value Units Raw File
Total cur 0.00 Mg of C C:\Users\user\Documents\carbon_workspace\tot_c_cur.tif

Hi @Nayanathara -

Would you please post the logfile (.txt) that the model produces? It might give us an idea if something is going wrong. Thanks!

~ Stacie

Hi
when i running InVEST carbon model version 3.7, model completed successfully. But my output tif file (c_above_cur, c_below_cur, c_dead_cur and c_soil cur tif files) didn’t open. can you give me the reason behind from this.


Thank you