RIOS Pre-processor Error

Hi, I am Dhaval from India.

I am using RIOS for the first time, and have been facing issues with the pre-processing tool toolbox on ArcGIS. When I run the pre-processing tool with my data, it gives the following error :

Error processing Erosion Control objective: Failed to execute. Parameters are not valid.
ERROR 001000: Lookup field: Field Sed_Exp does not exist
Failed to execute (Lookup).

Error running script
Failed script RIOS-Pre-Processing…

Traceback (most recent call last):
File “C:\Program Files\RIOS 1.1.16 x86\”, line 1276, in
raise Exception

Failed to execute (RIOS-Pre-Processing).
Failed at Tue Oct 22 11:12:38 2019 (Elapsed Time: 5.29 seconds)

I have checked the biophysical table csv for column names as I don’t find any discrepancy in terms of what the RIOS User Guide mentions (attached)00_Aurangabad_Biophysical_Coefficients.csv (778 Bytes). To reconfirm, I also ran the pre-processing tool on the sample data for Gura watershed and I am still getting the same error as above.

Can anyone please help me identify the problem?

In addition, are there step-by-step instructions for calculating the outputs of the pre-processing outside of ArcGIS that anyone can share with me.

Thank you in advance for your support.

Dhaval Negandhi
The Nature Conservancy, India

Hi Dhaval -

We’ve seen this error before when using a newer version of ArcGIS than what the 1.1.6 preprocessor was built on. Here’s a version of the toolbox created on Arc 10.4.1, which may or may not work for you, depending on the vagueries of Arc scripting compatibility. Unfortunately, it hasn’t been a priority for us to continually update this for newer versions of ArcGIS.

However, a wonderful user at Viridian Logic ported the pre-processor to open source code, which does not require ArcGIS, and I highly recommend giving it a try - here’s his page on GitHub. That will be much easier than doing it manually.

~ Stacie

Thank you very much Stacie for your prompt and very helpful advice. The version of pre-processing tool box you shared has worked – I have ArcGIS

Thanks again for your help. Have a great weekend!