Visitation: Recreation and Tourism fails when calculating photo-user-days

I am performing a calculation with InVEST Visitation: Recreation and Tourism. After adding input data and clicking the run button it succesfully grids the area of interest (althought took 1 hour) and then fails when importing photo-user-days from the server.

I attach the log file. However, some sentences are in spanish. I am using an university PC where is very difficult to make changes without admiinistrator permissions. Nevertheless, python error messages are in english so I think that would not be a great problem. I ran the model a week ago with the sample data and this did not happen.

Could the check if the server is working correctly? I read some closed topics with similar problems in this forum which were solved this way.

Thanks in advance.
Regards,
David
log_file.txt (5.8 KB)

Hello again. I do not know if this is relevant. My area of interest is Galicia (Northwestern Spain). Just in case.

Hi @david , thanks for letting us know. I checked the server and it’s responding normally for me now. When you ran the model a week ago were you on the same university network? If so, I would say it could have been just a dropped network connection and you could try again.

If you have never been successful on that network, then there could be network configuration things, like firewall rules, that are getting in the way. Though it’s more common to see a ConnectionRefused rather than a TimeoutError in those cases. And there’s not much we can do about it from our end unfortunately.

If you do keep trying and want to avoid the 1 hour of gridding the Area of Interest, there are two good options:

  1. Always use the same workspace (the model will re-use the AOI it gridded from a previous run) or
  2. Use a different workspace, but find the gridded version of the AOI from a previous run (it will be intermediate/aoi.shp) and use it as the AOI for your next run, and uncheck the “Grid AOI” option in the user-interface.
1 Like